=7.1.3,无奈之下,只能想办法升级wamp的PHP版本到7.1.30以上。其实很简单。1. 下载要安装的PHP版本https://www.php.net/downloads.php,这里要注意一下x64和x86...">

wampserver升级到PHP版本到7+

windows系统下,目前wampserver的最高版本为3.0.6,其中的PHP最高版本为7.0.10,博主想要安装laravel5.6最新版本,却看到需要PHP版本>=7.1.3,无奈之下,只能想办法升级wamp的PHP版本到7.1.30以上。其实很简单。

1. 下载要安装的PHP版本https://www.php.net/downloads.php,这里要注意一下x64和x86

2. 解压到 Wamp的安装目录\bin\php\phpx.x.xx下,自建版本相对应的文件夹

3. 从已存在的php版本文件中(7.0.10)复制以下文件: zend_ext目录、php.ini文件、phpForApache.ini文件、wampserver.conf文件 到7.1.30文件夹.

4. 打开php7.1.30文件夹的以下文件:  php.ini 和 phpForApache.ini 并且把其中所有的 7.0.10 替换为 7.1.30。

5. 打开Apache的conf目录下的 httpd.conf 文件:找到LoadModule php7_module 部分,将后面的7.0.10 改为 7.1.30

  • 1
    点赞
  • 1
    评论
  • 3
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值